Homing et switch de fin de course

Montages, améliorations, trucs et astuces concernant cette machine que beaucoup d'entre-vous apprécient.
qla
Nouvel Inscrit
Messages : 4
Enregistré le : 12 juin 2019, 17:22

Homing et switch de fin de course

Message non lu par qla » 21 avr. 2020, 19:31

Bonjour,

J'ai donc une 3018Pro sur laquelle je viens d'installer des switch de fin de course. J'ai ensuite configuré les paramètres qui vont bien (du moins de ce que j'en ai compris...) dans grbl soit les paramètres $21, $22, $23, $27 et $25 pour réduire la vitesse d'approche. J'ai donc la configuration suivante :
$$
$0=10
$1=25
$2=0
$3=5
$4=0
$5=0
$6=0
$10=3
$11=0.010
$12=0.002
$13=0
$20=1
$21=1
$22=1
$23=2
$24=25.000
$25=250.000
$26=250
$27=1.000
$30=1000
$31=0
$32=0
$100=1600.000
$101=1600.000
$102=1600.000
$110=1000.000
$111=1000.000
$112=800.000
$120=30.000
$121=30.000
$122=30.000
$130=300.000
$131=180.000
$132=38.000

Jusque là tout va bien.

Si j'ai bien compris normalement le cycle du homing en résumé est le suivant :
- détection de la limite du Z avec retrait de $27
- avance en X et Y jusqu'à détection du premier switch. Lorsque celui-ci est détecté, la course de cet axe s'arrête et l'autre axe continue jusqu'à déclencher lui aussi son switch
- retrait de $27 sur les axes X et Y

Or dans mon cas voici ce qui se passe :
- détection de la limite du Z avec retrait de $27 => De ce côté là tout est normal
- avance en X et Y jusqu'à détection du premier switch. Sauf que chez moi au lieu que le deuxième axe continue sa course, le déclenchement du premier switch sur un des deux axes stop les deux axe.
- ensuite j'ai bien un retrait de $27 sur les deux axes X et Y sauf que le dernier axe qui n'a pas déclenché son switch reste là ou il était lorsque le premier a déclenché...
J'ai bien lu l'article de https://lebearcnc.com/grbl-homing-et-fins-de-course/ et celui sur les paramètres de GRBL mais je n'y ai pas trouvé de piste sur ce problème...
Est-ce que quelqu'un a déjà rencontré ce problème ou a une idée ?
D'avance merci à vous.
Quentin.
Avatar du membre
DranerB
Administrateur
Messages : 1806
Enregistré le : 31 janv. 2019, 11:56
Localisation : Bourbon-Lancy, France
A remercié : 101 fois
A été remercié : 196 fois
Contact :

Re: Homing et switch de fin de course

Message non lu par DranerB » 22 avr. 2020, 00:46

qla a écrit :
21 avr. 2020, 19:31
Bonjour,

Jusque là tout va bien.

Si j'ai bien compris normalement le cycle du homing en résumé est le suivant :
- détection de la limite du Z avec retrait de $27
- avance en X et Y jusqu'à détection du premier switch. Lorsque celui-ci est détecté, la course de cet axe s'arrête et l'autre axe continue jusqu'à déclencher lui aussi son switch
- retrait de $27 sur les axes X et Y

Or dans mon cas voici ce qui se passe :
- détection de la limite du Z avec retrait de $27 => De ce côté là tout est normal
- avance en X et Y jusqu'à détection du premier switch. Sauf que chez moi au lieu que le deuxième axe continue sa course, le déclenchement du premier switch sur un des deux axes stop les deux axe.
- ensuite j'ai bien un retrait de $27 sur les deux axes X et Y sauf que le dernier axe qui n'a pas déclenché son switch reste là ou il était lorsque le premier a déclenché...
J'ai bien lu l'article de https://lebearcnc.com/grbl-homing-et-fins-de-course/ et celui sur les paramètres de GRBL mais je n'y ai pas trouvé de piste sur ce problème...
Est-ce que quelqu'un a déjà rencontré ce problème ou a une idée ?
D'avance merci à vous.
Quentin.
On ne peut pas avoir $20 et $21 tous les deux actifs. C'est soit l'un, soit l'autre. A priori $20=1, $21=0

Pour ton problème, c'est compliqué à diagnostiquer à distance. Première chose : ça fait pareil, que ce soit X ou Y qui déclenche en 1er ? Ce qui me vient à l'esprit : problème de câblage, peut probable, problème d'interférence, bruit électromagnétique, plus probable.

Un peu de lecture qui peut aider:
https://discuss.inventables.com/t/guide ... ches/16588
Bien Cordialement,
Bernard
Image
qla
Nouvel Inscrit
Messages : 4
Enregistré le : 12 juin 2019, 17:22

Re: Homing et switch de fin de course

Message non lu par qla » 22 avr. 2020, 10:54

Bonjour,

Tout d'abord merci pour ta réponse.
Pour $20 et $21 effectivement. Initialement je n'avais qu'un seul des deux paramètres activé. En désespoir de cause, j'ai fini par activer les deux hier en faisant des tests. Mais le problème est identique avec un seul des deux paramètres activé...
Oui le problème est identique que ce soit X ou Y qui déclenche en premier.
Si le problème est effectivement dû à des interférences ou à un bruit électromagnétique, y'a-t-il un moyen de régler ça ?

Merci pour le lien, je vais regarder ça.
jean-claude garnier
Compagnon
Messages : 100
Enregistré le : 04 mai 2019, 03:37
Localisation : Capitale des Gaules
A remercié : 3 fois
A été remercié : 18 fois

Re: Homing et switch de fin de course

Message non lu par jean-claude garnier » 22 avr. 2020, 11:20

Bonjour
J'ai eu des soucis d'interférences identiques sur la machine de Cobois >>>, j'ai cru que j'allais jamais m'en sortir jusqu'à trouver ça :
Résistance pull up
Pour des raisons liées aux technologies des circuits logiques, les électroniciens préfèrent utiliser une résistance pull up (résistance de tirage vers le haut) entre l’entrée et l’alimentation (5 V dans le schéma ci-après) et connecter le poussoir comme suit.
( Résistance 5 à 10k )

unnamed.png
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Image
qla
Nouvel Inscrit
Messages : 4
Enregistré le : 12 juin 2019, 17:22

Re: Homing et switch de fin de course

Message non lu par qla » 09 mai 2020, 13:51

Bonjour,
Bon j'ai fini par résoudre mon problème sans vraiment savoir comment. A force de faire des tests, j'ai fini par défaire tous mes câblages, tout recâbler et la ça fonctionne. J'ai pourtant l'impression d'avoir remis comme je l'avais fait initialement mais peut-être avais-je fait une erreur dans mon câblage initial...

Merci à vous pour votre aide.
Quentin.
jean-claude garnier
Compagnon
Messages : 100
Enregistré le : 04 mai 2019, 03:37
Localisation : Capitale des Gaules
A remercié : 3 fois
A été remercié : 18 fois

Re: Homing et switch de fin de course

Message non lu par jean-claude garnier » 09 mai 2020, 14:42

qla a écrit :
09 mai 2020, 13:51
peut-être avais-je fait une erreur dans mon câblage initial...
C'est pas à exclure, ça le fait des fois : on a le nez dessus et on voit rien
Tant mieux. Reviens nous montrer tes trucs et tes machins que t'auras faits.
Image
Répondre